Jump to content

Advertisement



xSellize For Sale

All offers should be directed here

Photo

Removing Dependencies from Cydia apps?


  • Please log in to reply
23 replies to this topic

#1
homeyg

homeyg

    Whats an iPhone

  • Members
  • PipPip
  • 25 posts
Hi would anyone please do me a favor and remove the dependency for Notified Pro from the Notification Bar for Notified app?

the deb is included as an attachment. Thanks :)

Attached Files


  • 0

x-bot

x-bot

    x-bot

  • Ad-Bot
  • Ad post



#2
mohaas05

mohaas05

    Senior Member

  • Members
  • PipPipPipPipPipPipPip
  • 346 posts
Why? Generally apps have dependencies because they require them to function.
  • 0

#3
kameko

kameko

    Jailbroken

  • Members
  • PipPipPipPipPipPipPip
  • 111 posts
are you an idiot? you essentially want to get rid of the main program and ONLY run the plugin for it? get a brain.
  • 0

#4
qazpie

qazpie

    Whats an iPhone

  • +Contributor
  • PipPip
  • 17 posts
actually what he requested makes sense and i would also like it
see its cuz notificationbar needs notified pro which is very very buggy, so i prefer the free version of notified
if you removed the dependency, then you could use this with the free version..
thanks in advance to anyone who could fill this request :D
  • 0

#5
thecramps

thecramps

    Senior Member

  • Members
  • PipPipPipPipPipPipPip
  • 166 posts
So you just need the dependency removed? Ill repack it when I get home.
  • 0

#6
thecramps

thecramps

    Senior Member

  • Members
  • PipPipPipPipPipPipPip
  • 166 posts
http://www.mediafire...6bpa3up1wsg5zus

Is this what you needed?
  • 0

#7
homeyg

homeyg

    Whats an iPhone

  • Members
  • PipPip
  • 25 posts

http://www.mediafire.com/?6bpa3up1wsg5zus

Is this what you needed?


Thank you thats exactly what i needed :)
  • 0

#8
homeyg

homeyg

    Whats an iPhone

  • Members
  • PipPip
  • 25 posts

are you an idiot? you essentially want to get rid of the main program and ONLY run the plugin for it? get a brain.


are you an idiot? this package requires the paid version of the app and since this is a cracking website that hosts a cracked version of the software, maybe, JUST MAYBE, im using the cracked version and cant install it without the dependency removed. think next time you try and insult someone
  • 1

#9
thecramps

thecramps

    Senior Member

  • Members
  • PipPipPipPipPipPipPip
  • 166 posts

Thank you thats exactly what i needed :)


No problem, but next time you could do it yourself and here is how

1. Download 7 zip, unzip the debian
2. there will now be 2 files, control and data, unzip these with winrar or something like that
3. go in the control folder, edit the control file, you will find a dependency line, change what dependencies you want to add/remove

your done, now just repack it
to do so

1. make a folder called whatever the .deb is to rename, for instance here, "Notified"
2. make a folder inside that folder called DEBIAN, copy the control file inside the old control folder here
3. next just take the data folder an put in inside the Notified folder
4. Drag the notified folder to SSH /var/root/
5. type CTRL + T, type this "dpkg -b "Notified" Notified.deb"
- dpkg -b (means build a deb)
- "Notified" (is the folder)
- Notified.deb (is the new .deb)

Done, you just removed a dependency


If you need any more help just ask
  • 5

#10
bmaffin13

bmaffin13

    Whats an iPhone

  • +Contributor
  • PipPip
  • 13 posts
Thanks man. Been wondering how to do this for sometime now. Will be helpful with quite a few packages I want!
  • 0

#11
Mike_Rotch

Mike_Rotch

    Senior Member

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 829 posts
book marked this thread simply because what thecramps said in the last post was very very helpful/useful for the future.
  • 0
Xbox Live Gamertag: Bret Heimsness
GameCenter Tag:
Mike Rotch

#12
vinaygoel2000

vinaygoel2000

    xSellize Fan

  • +Contributor
  • PipPipPipPipPipPipPipPipPipPip
  • 2852 posts

No problem, but next time you could do it yourself and here is how

1. Download 7 zip, unzip the debian
2. there will now be 2 files, control and data, unzip these with winrar or something like that
3. go in the control folder, edit the control file, you will find a dependency line, change what dependencies you want to add/remove

your done, now just repack it
to do so

1. make a folder called whatever the .deb is to rename, for instance here, "Notified"
2. make a folder inside that folder called DEBIAN, copy the control file inside the old control folder here
3. next just take the data folder an put in inside the Notified folder
4. Drag the notified folder to SSH /var/root/
5. type CTRL + T, type this "dpkg -b "Notified" Notified.deb"
- dpkg -b (means build a deb)
- "Notified" (is the folder)
- Notified.deb (is the new .deb)

Done, you just removed a dependency


If you need any more help just ask

I just tried this method for SBSettings to remove Activator dependency. Just wanted to confirm before I do something crazy. I saw the line below:

Depends: libhide (>= 2.0.6-4), mobilesubstrate, sbsettingstoggles (>= 3.0.5), shell-cmds, firmware (<< 4.0) | libactivator (>= 1.3.2)

So, should the line look like this:

Depends: libhide (>= 2.0.6-4), mobilesubstrate, sbsettingstoggles (>= 3.0.5), shell-cmds, firmware (<< 4.0) |

or

Depends: libhide (>= 2.0.6-4), mobilesubstrate, sbsettingstoggles (>= 3.0.5), shell-cmds
  • 0

#13
Mike_Rotch

Mike_Rotch

    Senior Member

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 829 posts
thecramps, i tried to do your method with psx4all but there is no control file. do i need to download the official version for it to work (which i could)? i'm trying to remove both dependencies because they use too much battery for my phone.

nvm psx4all won't work without 1 btstack file. damn :(

Edited by Mike_Rotch, 30 August 2010 - 11:24 PM.

  • 0
Xbox Live Gamertag: Bret Heimsness
GameCenter Tag:
Mike Rotch

#14
Kaibil

Kaibil

    Whats an iPhone

  • Members
  • PipPipPip
  • 44 posts
I am in the same boat, I have notified pro listed in cydia / packages and the only option I see is Purchase in the upper left corner, I don't get the remove option.

I tried upgrading to 1.4x but t will not let me, it gives me an error trying to overwrite/System/Library/CoreSevice/Springboard.app/FSO_Notified,png, which is in package com myrpospace.atomicmffin.notifiedpro.

If I try the same package from another source, the same thing appears. I think is the dependency issue.

I do not need to upgrade, I will ok with just removing the whole package, I don't know how this happened and would like to know how to avoid the same issue in the future.
Thank you
Mario
  • 0

#15
Traavis

Traavis

    Senior Member

  • +Contributor
  • PipPipPipPipPipPipPipPipPipPip
  • 684 posts
Remove /System/Library/CoreSevice/Springboard.app/FSO_Notified,png and try again
  • 0

#16
oscahie

oscahie

    Jailbroken

  • Members
  • PipPipPipPipPip
  • 69 posts

I just tried this method for SBSettings to remove Activator dependency. Just wanted to confirm before I do something crazy. I saw the line below:

Depends: libhide (>= 2.0.6-4), mobilesubstrate, sbsettingstoggles (>= 3.0.5), shell-cmds, firmware (<< 4.0) | libactivator (>= 1.3.2)

So, should the line look like this:

Depends: libhide (>= 2.0.6-4), mobilesubstrate, sbsettingstoggles (>= 3.0.5), shell-cmds, firmware (<< 4.0) |

or

Depends: libhide (>= 2.0.6-4), mobilesubstrate, sbsettingstoggles (>= 3.0.5), shell-cmds


Should be without the last bar, but I don't think the current version of SBSettings can work without Activator, it seems to be the only way to trigger it. Post the results, anyway, I'd also like to get rid of Activator...
  • 0

#17
munaim1

munaim1

    Advanced Member

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 685 posts
Could some please remove a dependecy from this please, I'v had a few difficulties trying to get it to save the file after i'v edited with 7-zip.

The line I would like removed is Depends: com.gbtech.repoicons

http://www.mediafire...byx77ncel7kec5d


Thanks you :thumbsup:
  • 1

#18
MCFarmfresh

MCFarmfresh

    Senior Member

  • Members
  • PipPipPipPipPipPipPip
  • 101 posts
Could some please remove a dependecy from this please, I'v had a few difficulties trying to get it to save the file after i'v edited with 7-zip.

The line I would like removed is Depends: com.gbtech.repoicons

http://www.mediafire...byx77ncel7kec5d

I have been looking for the exact same thing! I have been scouring the net for the rep icons themselves to just install them and be done with it but I have had no luck :(. So if someone could remove the repo icon dependencies from the file I would sooo apreciate it. I attempted to do it as per above instructions but I don't know enough about zip files and modifying them to make it work. Thanks!!
  • 0

#19
munaim1

munaim1

    Advanced Member

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 685 posts

Could some please remove a dependecy from this please, I'v had a few difficulties trying to get it to save the file after i'v edited with 7-zip.

The line I would like removed is Depends: com.gbtech.repoicons

http://www.mediafire...byx77ncel7kec5d

I have been looking for the exact same thing! I have been scouring the net for the rep icons themselves to just install them and be done with it but I have had no luck :(. So if someone could remove the repo icon dependencies from the file I would sooo apreciate it. I attempted to do it as per above instructions but I don't know enough about zip files and modifying them to make it work. Thanks!!



HERE YOU GO

imemory enhancer1.0 WITHOUT DEPENDENCIES

http://www.mediafire...blzyjqlkz46dfdv

Havn't tested it myself coz im using supercharged vm mod on my 3g. let me know if it doesn't work.
  • 1

#20
MCFarmfresh

MCFarmfresh

    Senior Member

  • Members
  • PipPipPipPipPipPipPip
  • 101 posts
Thanks for your effort munaim1. I installed it through terminal and it gave me an error "dpkg: error processing memEnhance_1.0_NO_DEPEND.deb (--install); cannot access archive: No such file or directory Errors were encountered while processing: memEnhance_1.0_No_DEPEND.deb" I don't know if i did something wrong in installing it. I used the dpkg -i command. I did a little research on zip files and I modified the original memEnhance file myself and just removed the line of code"Depends" and the line of text after it, repacked it and installed on my phone and it really messed it up. After i installed the one i modified it deleted everything in cydia. There was nothing under Packages or Sources or anywhere else. I got an error saying imemenhancer was very unstable when i launched cyda. I redownloaded the original .deb and installed it and it fixed it. I did all this before trying your package manaim1. Yours didnt effect my device like mine did so i am not sure what to do. I'm gonna keep trying to educate myself and see if i can figure out how to remove the dependancy correctly. Thanks everyone!
  • 0




IPB skins by Skinbox
-->